Author Topic: TH350 accumulator cover troubles..  (Read 3281 times)

ling427ttvette

  • Hero Member
  • *****
  • Posts: 1526
  • Karma: 5
TH350 accumulator cover troubles..
« on: November 02, 2012, 05:14:23 PM »
The accumulator cover was leaking on my moms 80 Chevy 1/2 ton.

I pulled it apart, found the spring in there in 4 pieces. The o-ring looked to be in good shape, so I stuck it back together with a new spring and all was well until I drove it. Started leaking worse.

So, last night I tore it apart again and had some troubles getting the cover to pop off, like I did the first time. So, I turned the engine over so it would build up a little pressure and pop it off, and it worked.. only this time it popped an extra piece out that I cannot get to go back in:



The piece on the right hand side that the spring is sitting in. There's a hole for it to go into, but I cannot get it to go back in all the way. There's no room to get a hammer in there and tap it in. Anyone ever mess with one of these, or have any ideas?

NovaDK13

  • Hero Member
  • *****
  • Posts: 609
  • Karma: 1
Re: TH350 accumulator cover troubles..
« Reply #1 on: November 02, 2012, 06:39:00 PM »
Can you just remove the cross member bolts and a jack under the trans to lower it enough to get it? Just an idea

ling427ttvette

  • Hero Member
  • *****
  • Posts: 1526
  • Karma: 5
Re: TH350 accumulator cover troubles..
« Reply #2 on: November 02, 2012, 11:40:29 PM »
Problem solved. Greased it up real well, got a short short screw driver and tapped on it lightly. Fell right in.

Finally done with that head ache.. tomorrow it gets an a/c compressor and valve cover gaskets and its done.