Author Topic: Trans Am not starting...  (Read 7227 times)

Mr. Luos

  • Hero Member
  • *****
  • Posts: 1780
  • Karma: 19
  • HERRO
Re: Trans Am not starting...
« Reply #25 on: September 27, 2011, 05:38:57 PM »
The fuel pump has a sock over it inside the tank to attempt to prevent the shit getting sucked up.
BUT....that could be crusty too if it sat mostly dry.
2009 BMW 335i

2008 Chevy TBSS. Just a riced 440HP SUV. SOLD

Riced '99 Trans Am WS.6 SOLD
Dropped, wheels, slow.

Southern_Pride

  • Hero Member
  • *****
  • Posts: 930
  • Karma: 1
  • Whoopie ti yo
Re: Trans Am not starting...
« Reply #26 on: September 27, 2011, 05:54:46 PM »
Those screens only help so much. My bronco would get mud in the tank and suck it through the screen, then lock up the pump. Let it sit a few hours, dirt would fall out, truck ran fine again till it would plug the fuel filter. And you can back flush them 3 times before they need replaced in reality.

Onyx Dragon

  • Super Administrator
  • Hero Member
  • *****
  • Posts: 9926
  • Karma: -66
Re: Trans Am not starting...
« Reply #27 on: September 27, 2011, 11:15:14 PM »
Those screens only help so much. My bronco would get mud in the tank and suck it through the screen, then lock up the pump. Let it sit a few hours, dirt would fall out, truck ran fine again till it would plug the fuel filter. And you can back flush them 3 times before they need replaced in reality.

It's never been in mud, so I doubt it would be that extreme.

Onyx Dragon

  • Super Administrator
  • Hero Member
  • *****
  • Posts: 9926
  • Karma: -66
Re: Trans Am not starting...
« Reply #28 on: December 17, 2011, 09:24:32 PM »
Ok, turns out it was the fuel pump and the relay.  Changed the relay, started, turned the car off, didn't start.  Changed the pump, car starts every time.  My sister is being kind enough to bring it down this coming week when she visits.

Kalgorn

  • Super Administrator
  • Hero Member
  • *****
  • Posts: 14092
  • Karma: 28
Re: Trans Am not starting...
« Reply #29 on: December 18, 2011, 12:23:23 PM »
Sucks you had to replace the fuel pump but at least it's done and you shouldn't have to worry about it now.

2002 Silverado | 1995 Talon TSi AWD | 1989 Prelude Si 4WS

angry hampster

  • Administrator
  • Hero Member
  • *****
  • Posts: 5022
  • Karma: 38
    • Lexa Photography
Re: Trans Am not starting...
« Reply #30 on: December 19, 2011, 08:45:58 AM »
Sucks you had to replace the fuel pump but at least it's done and you shouldn't have to worry about it now.

Yeah -- looking forward to seeing progress on a RUNNING car now, Onxy. :)

Onyx Dragon

  • Super Administrator
  • Hero Member
  • *****
  • Posts: 9926
  • Karma: -66
Re: Trans Am not starting...
« Reply #31 on: December 19, 2011, 02:43:50 PM »
Yeah -- looking forward to seeing progress on a RUNNING car now, Onxy. :)

Which won't happen until I get out of this cast and can go get it :P